Flv Crunch Help

File formats
Obtaining video files
Frame rates
Adding Files to be Converted
Destination Folder
Starting the Process
Stopping the Process
Sound Settings
Improving Quality
Statistical Data
Cropping a video
Selecting a Certain Time in a File
Preserving Aspect Ratio
Additional Commands
Conversion Menu


Flv Crunch is a program made to convert video files into another format. 

flv, mpg, vob, mp4, mov, avi, 3gp, dv, wmv, wma, ra, rm, mp3, m4a, mkv, mka, m4v, aac, aiff, flac, mod, and wav.

mpg, vob, mp4, mov, avi, 3gp, mp3, m4a, wmv, dv, flv, mkv, and aiff.

You might use this program to make a YouTube video into something your iPod can play.

Why is this program called Flv Crunch when it converts many video formats?
Originally it was for converting videos downloaded from YouTube into playable files. This felt too limited so I expanded the program to include other formats.

File Formats

There are several different file formats to choose from when converting your video file. Each format has its advantages and disadvantages. Here is a breakdown of each format.


QuickTime MOV








This table list the video and audio codec used with each file type.

Extension Video Codec Audio Codec
mpg mpeg1video mp2
vob mpeg2video mp2
mp4 mpeg4 aac
mov mpeg4 aac
avi DivX mp3
dv video
pcm 16 bit
ms mpeg4 v3
wma version 2
3gp h.263 aac
mp3 none mp3
pcm 16 bit

Obtaining video files

The largest collection of video files in the world is the web site YouTube.com. There are also several other video sites that use video files such as Google Video. In order to obtain a video file from YouTube, the video must be ripped. There are several sites that provide this service. A lot of these sites tend to fail when YouTube makes changes to their site. To find such as site, type in "Youtube ripper" in your favorite search engine. Hopefully one of these sites will actually work. The one method that consistently works is using Safari web browser to do it.

The Safari web browser method

When watching a YouTube video in Safari, click on the "Window" menu and select "Activity". There you will see a list of files, their size, and their download rate. The file that is the video file is the one with the largest size. This is usually in the MB range while all the pictures and text are in the KB range. Double click this file and Safari will start downloading the video file in the "Downloads" window. When the file finishes downloading, add the extension ".flv" to the end of the file name.

Safari activity window



Resolution refers to the dimensions of the video. There are many different sizes to choose from. It is best to consider where the video is going to be played when changing its size. Most of the time it is best to keep the original resolution. If the video to meant to be played on a small screen like a cell phone or pda, then reducing the size of the video makes sense.

To change the resolution, uncheck the ‘keep original value’ checkbox. You may enter a value into the width and height fields or select one of these presets.




Standard Definition

High Definition

Note: The 3gp format will have only preselected resolutions available. This is a limitation of the used video codec.

The menu that is available for the width and height can be used to resize videos also. The numbers that are in there represent how much to multiply the video's original dimension by. If you were to select 1/2 for the width, the output file size would have half the width of the original video file. If you selected x2, the created video would have a width that is two times the original video's width.

The "Calculate" item gives the user the ability to resize video files with any letterboxing, stretching, or shrinking. This is how it works. Say you know you want the new video size to be 500 pixels wide. You would enter 500 in the width field, then select "Calculate" in the height field's menu. What this does is have the program calculate the new height of the video file so that the new file will have the same aspect ratio as the old one.

Frame rates

This controls how many pictures are displayed in a second. Reducing the frame rate will make the video easier to play back on slower systems and reduce the size of the video file. Note: for the mpeg 2 format, there is a limited number of frame rates available. The other video formats (except for mpeg 1 and dv) allow any number of frames per second. To change the frame rate simply select the “no change” text. Delete it. Then enter your desired value.


The bitrate in a video file is just like the bitrate in a mp3 file. The higher the bitrate, the better the video quality will be. Higher bitrates lead to larger files. It is usually best not to change the bitrate. To change the value, click the blue box with the black arrow in it to select a preselected value, or delete the ‘no change’ text and enter a value. The value must be greater than 0. Please note that when an application like Quicktime Player tells you the bitrate (Data Rate), it is giving you the value of the video stream plus the value of the audio stream. This is one reason why the set bitrate and the actual bitrate don't match. Another problem with setting the bitrate is there is a limit on how low and how high a certain video file's bitrate can be. This is largely cause by the resolution of the video file. If you wish to use the bitrate feature, the quality should then be set to "automatic". The quality feature will interfere with the bitrate feature otherwise.

When using the mp3 or m4a formats, only a limited number of bitrates will be available. This is due to these formats' specification.

Adding Files to be Converted

To add files to be converted, simply push the Add button. A dialog will show up for you to select the files you want to convert. Multiple files can be selected at one time by holding down the command key and clicking on the files in the dialog box that are desired. Files may also be added by dragging them from the Finder onto the file list area. To remove files from the conversion list, click on the file and push the Remove button, or by pushing the delete button on the keyboard.  Files can be added to or removed from the list while a conversion is taking place.

Destination Folder

The Destination folder is where the converted files are saved. The default location is the Desktop folder. To change the location, push the Change button. A dialog box will show up and you can then select the destination folder. The destination can also be changed by simply typing in a new destination. Make sure the new destination exists before the conversion starts.

Starting the Process

Push the Start button to start the whole conversion process.

Stopping the Process

The Start button turns into the Stop button when the conversion process is active. Pushing the stop button halts the conversion process.

Sound Settings

sound menu

The sounds options are No Change, Stereo (two speakers), Mono (one speaker), or No Sound. When the converted file is meant for a cell phone, it is usually best to select mono. If you were interested in only the video part of a file, then selecting No Sound would be the option to use. For listening to the file using a dual speaker system, Stereo would be the option to choose. Of course No Change is just fine if you are happy with the sound.

The sampling rate is the number of audio samples taken in a second. If you don't understand what that means, it's ok. Only a few things need to be known about this feature. One thing is the sampling rate of an audio cd is 44.1 KHz. Having a higher sampling rate than that is usually not necessary. Another thing to know about sampling rate is the higher it is, the bigger your file is going to be. The last thing to note is each audio codec has its own allowable sampling rate values.

To change the sampling rate of a sound file, click on the 'Sound' menu and select Sampling Rate. Then select the sampling rate you wish to use. The 'Automatic' item is selected by default which means the program will handle any sampling rate issues for you.

The volume of a sound file can be changed. Click on the 'Sound' menu and select 'Volume (%)'. The values represent a percentage of the original volume. To increase the volume of a sound file, select a value that is greater than 100. To decrease the volume, select a value that is less than 100.

Improving Quality

  quality menu

The quality of a video file can be controlled by selecting one of the items from the Quality Menu. The automatic menu item attempts to strike a balance between Speed and Quality. No Change gives a video file that is about the same quality as the original. This quality setting is usually good enough. The high, medium, and low options will give lower quality videos, but in smaller file size. A little experimenting will help you learn which option is best.

Statistical Data

Statistics window

Statistics for the program are available. Go to the "File" menu and choose "Statistics".  The information there tells you the following:

Converted Files:                   Files converted since starting up Flv Crunch.
Total Conversion Time:       Total time spent converting files since the program was started.
Average Time Per File:       Average time spent converting each file since the start of the program.
Files In List:                        Tells how many files are in the file list.
Total Converted Files:         Number of converted files since user first started using this program.
Total Conversion Hours:     The number of hours spent converting files.

The reset button resets all the fields in the current session area to zero. The "Total Converted Files" field can not be reset to zero. It acts as the odometer of the program telling you how many files you have converted since this program was first used by the current user. The "Total Converting Hours" field also can't be reset.

Cropping a video

The Crop window

A video file can be cropped so that only certain areas of a video are shown. Simply click on the Video menu and select Crop to use this feature. Just enter the number of pixels you want removed from each side. Then push the Set button. Please note that all numbers entered must be even.

To disable this feature, simply open the window again and click the cancel button.

Selecting a Certain Time Interval in a File

Timings window

This feature allows the user to specify a certain time in a file to use. This is useful when only a part of a video file is needed. Click on the File menu and select "Time Interval" to open the above window. To select the starting position in the file, click on the Start time text field. Then enter the start time. The format of the time is hours:minutes:seconds. To select a start time of 1 minutes 23 seconds, the entered value would be 00:01:23. To enter an ending time, select the End time text field, and enter the the desired end value. An example end time of 1 hour, 13 minutes, and 33 seconds would be entered as 01:13:33. Be sure the radio button next to the End time text field is selected when using a custom end time.

To activate this feature, push the Set button.
To deactivate the feature, push the Cancel button.
To reset the window to default values, push the Reset button.

Preserving Aspect Ratio

When resizing a video, the width to height ratio should be the same. When the width to height ratio of a video is changed, it leads to undesirable stretching and shrinking. To prevent this from happening, go to the Video menu and select "Same Aspect Ratio". This will allow you to resize the video with little or no stretching or shrinking. This feature isn't perfect. Sometimes a video looks better with the feature disabled. It works by adding black rectangles on two of the sides. This is known as letterboxing.


Preference window

The preferences feature allows the user to select the default format, default save location, and the version of FFmpeg (the conversion engine) that will be used in each conversion session. Release 0.5 is the newest version and suggested for use. The available versions of FFmpeg change with the operating system. Here is a breakdown of what you can use:

Revision 7000, Release 0.5:                     Mac OS 10.1 or greater
Revision 12000:                                       Mac OS 10.3 or greater

The "Test Engine" button is used to see if the selected version of FFmpeg would run on your system. If it does, you will see a message in the display area stating which version of FFmpeg is running. If it fails, an error message will display.

The "Print engine messages" option causes all messages ffmpeg outputs to be sent to the Console. These messages can be viewed by using the "Open Error Log" menu item from the "File" menu.

The "When done converting" options are what the program can do when it is done converting all your files.

Bounce dock icon:     causes Flv Crunch's icon to bounce up and down (only when the application is in the background).
Beep:                         plays the computer's default alert sound.
Display alert:             displays a dialog telling the user the conversion process has finished.
Quit:                          causes Flv Crunch to quit.
Sleep:                        causes the computer to go to sleep immediately.

Additional Commands

The additional commands window

FFmpeg is the engine used to convert video files. It is a free, open source program that any one can build and run. For those people who know how to use it, this feature allows for you to send additional commands to it. This page contains all the directions to the program: http://ffmpeg.org/ffmpeg-doc.html. An example command to use is this one to deinterlace a video file: -deinterlace.

This command can create a video files that can be played on very old computers: -vcodec mjpeg -acodec pcm_s8. I was able to create a video that played on a 68k Mac! Just remember to use it with the Quicktime Mov format.

To access this feature, click on the "File" menu and select "Additional Commands". Enter your command in the text field, then push the close button in the upper left-hand corner. If you wish to clear the text field, push the "Reset" button.

Conversion Menu

This menu gives the user several options when converting files. The "When Done" submenu gives the user options on what to do when a conversion has finished.
Beep:                     Plays the computer's default alert sound.
Display alert:         Displays a dialog telling the user the conversion process has finished.
Quit:                      Causes Flv Crunch to quit. Mutually exclusive with the "Shut Down" option.
Sleep:                    Causes the computer to go to sleep immediately. Mutually exclusive with the "Shut Down" option.
Shut Down:          Causes the computer to shut down after 30 seconds. Avoid using this option with other programs running. They can interfere or cause the loss of unsaved changes.

The "Reduce CPU Usage" option allows the user to reduce how much priority the conversion engine is allowed to have. When this option is active, other applications will be allowed to run more often than the conversion engine. This feature is useful for playing games or browsing the web while a conversion is taking place. It will make your computer feel a little faster. Turning off this feature isn't as easy. The operating system has to have an administrator enter their password in order to return the conversion engine's priority to normal. This currently has to be done via the Terminal application. If the "Reduce CPU Usage" menu is unchecked when a new conversion starts, the conversion engine's priority will return to normal.

The command to enter to return ffmpeg's priority to normal: sudo renice 0 -p <ffmpeg's pid>.  FFmpeg's pid will be displayed in the Console if you try to uncheck the "Reduce CPU Usage" menu item.

The "Pause" menu item pauses the conversion engine during a conversion. This feature is useful for giving another program full system resources temporarily. Selecting this menu item again resumes conversion of the current file.

The "Skip File" menu item makes Flv Crunch stop converting the current file and start converting the next file in the file list. This feature might be useful when the currently converting file is taking too long and you don't want to wait on it.


The video files used with this program must end with an extension in order for the program to recognize them. An example would be a flv file with a .flv at the end of the file name.

Flv Crunch might print messages about certain issues. To view these issues simply select “Open Error Log” from the File menu.

The issue with video files is they have a file format, audio, and video codecs that this program has to deal with. While this program can open certain file formats, it doesn't mean it can handle all codecs that are available to the file format.

Each version of ffmpeg included with this program have their strengths and weaknesses. If you notice a problem with one version, try your conversion again using a different version.

While converting to MPEG 1, the log might show multiple buffer underflow messages (if the "Print Engine Messages" option is on). You might also notice seeking problems if this problem takes place. This indicates that there are problems converting your file. Selecting "Automatic" from the "Quality" menu will fix this problem.

Converting files on a flashdrive while using a computer that is running Mac OS 10.1 is not suggested. The files should be copied onto the hard drive and then converted there.

Creating mpeg 1 files on Mac OS 10.1 and 10.2 can have its problems when using the ffmpeg-0.5 conversion engine. One work around is to convert the file into a mp4, then  switch the conversion engine to ffmpeg-7000 to convert the mp4 into a mpeg 1 file.


My email address is Programmingkidx@gmail.com. Feedback is always welcomed. Bug reports are also welcomed.